Some users of outdated GitHub Actions are experiencing occasional timeouts
Incident Report for Determinate
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 18:06 UTC
Monitoring
If you are experiencing timeouts while using Determinate Systems GitHub Actions, these new releases should resolve them:

- flake-checker-action v9
- flakehub-push v5
- magic-nix-cache-action v8
- nix-installer-action v14
- update-flake-lock v24

However, we're continuing to monitor this issue.
Posted Sep 09, 2024 - 16:55 UTC
Update
The timeouts are affecting an extremely small number of our users.
Posted Sep 09, 2024 - 16:38 UTC
Investigating
We are investigating an issue where Determinate Systems GitHub actions are experiencing timeouts.
Posted Sep 09, 2024 - 16:37 UTC
This incident affected: GitHub (GitHub Actions).