We have released Determinate Nix Installer v0.34.0, which includes a short-term workaround for Cachix users, and also corrects the mishandling of setting `experimental-features` in extra-conf.
Posted Jan 16, 2025 - 17:27 UTC
Update
We're going to temporarily write the trusted-users setting, if specified, to /etc/nix/nix.conf as well as /etc/nix/nix.custom.conf when users install upstream Nix. This will unblock our release process and allow us to continue moving forward.
We made this split so nix.conf is predictable, and nix.custom.conf is inspectable for what the user set. We're going to continue working on this as part of our roadmap.
* Determinate Nix will continue having trusted-users in the nix.custom.conf for the foreseeable future as part of providing a consistent user experience, and * We're planning on removing the duplicated trusted-users setting from nix.conf again in the coming weeks.
We've reached out to the Cachix team to help if we can.
Posted Jan 15, 2025 - 19:05 UTC
Update
The issue was not with Determinate Nix Installer, but specifically due to how the Cachix client parses the nix.conf. In an effort to preserve compatibility, we are going to keep the release rolled back for the moment while we monitor the Cachix bug report.
The rollback to v0.32.3 is complete, and we are now investigating the cause.
Posted Jan 15, 2025 - 14:05 UTC
Identified
Determinate Nix Installer v0.33.0 incorrectly generates nix.conf files with certain user specified configuration. Specifically, experimental-features and trusted-users are impacted.
We are rolling back 100% to v0.32.3 within the next 5 minutes. After that, we will identify the cause and enhance our testing systems to detect and prevent this in the future.
Posted Jan 15, 2025 - 14:00 UTC
This incident affected: GitHub (GitHub Actions) and Determinate Nix.