Back

Determinate Nix 3.8.0 users on macOS should upgrade to Determinate Nix 3.8.1 as soon as possible due to a security issue.

July 11, 2025 at 09:04 PM UTC Resolved after 7d

Updates

Resolved

We released Determinate Nix 3.8.1, and upstream has released Nix 2.30.1.
Please upgrade to these versions (or newer) as soon as possible.

July 19, 2025 at 12:07 AM UTC
Monitoring

For more information and instructions on how to upgrade, see our changelog: https://determinate.systems/posts/changelog-determinate-nix-381/

July 12, 2025 at 02:37 AM UTC
Identified

We have released Determinate Nix 3.8.1 which fixes this issue and are continuing to monitor for additional problems.

July 12, 2025 at 01:54 AM UTC
Identified

The v3 tag of determinate-nix-action has been rolled back to version 3.7.0 as well.

July 11, 2025 at 10:32 PM UTC
Identified

While we test the mitigation, we have issued a rollback to version 3.7.0.

July 11, 2025 at 10:16 PM UTC
Identified

We believe we have found the issue and are currently testing a mitigation.

July 11, 2025 at 10:05 PM UTC
Investigating

At this time, we believe the issue only impacts macOS users.

July 11, 2025 at 09:13 PM UTC
Investigating

Users of Determinate.pkg on macOS will get 3.7.0. You can redownload and run the macOS package to roll back. In CI, you can pin back to 3.7.0 via determinate-nix-action: https://github.com/DeterminateSystems/determinate-nix-action

July 11, 2025 at 09:05 PM UTC
Investigating

We're bisecting the changes in Determinate Nix 3.8.0 and Nix 2.30.0 to identify why some builds are failing that previously succeeded. We believe the issue is related to the build-dir changes.

July 11, 2025 at 09:04 PM UTC